#standarderror
How do you manage error classes in your app?

- Granular — Domain::Specific::NotFoundError
- Generic/Reusable — Error::NotFound
- Not — StandardError/raise 'x'

Personally, I create my own error classes so I can see what's wrong at a glance, even if it means catching existing ones.

#RubyLang
May 16, 2025 at 9:35 AM
#statstab #464 Should a pilot study change your study design decisions?

Thoughts: You shouldn't use the ES, but you can use the SD (see also #192) for planning.

#pilot #experiments #poweranalysis #standarderror #simulation #methodology #SD #TypeM

declaredesign.org/blog/posts/p...
Should a pilot study change your study design decisions? – DeclareDesign
declaredesign.org
January 15, 2026 at 7:13 PM
Man, this is a bit of work… third day spent on this I think 😅 #ruby #rubylang
January 8, 2026 at 9:57 PM
#statstab #192 Statistical Power from Pilot Data

Thoughts: One new use for pilot data - estimating the SE to power your study. If you can follow the formula. By @carlislerainey

#pilot #experiments #poweranalysis #standarderror #simulation #methodology

www.carlislerainey.com/blog/2024-06...
Carlisle Rainey - Statistical Power from Pilot Data: Simulations to Illustrate
In this post, I discuss how pilot data can be used to predict the standard error in a planned study.
www.carlislerainey.com
October 1, 2024 at 5:11 PM
Ah yeah, error handling is tricky… especially since if you want to catch every possible network-related one but without catching a completely generic type like StandardError, you end up with like two lines of things like OpenSSL::Error, SocketError, Errno::ECONNREFUSED and so on :P
July 5, 2023 at 11:14 PM
I honestly was not expecting to see this get fixed!

I ended up working around it by configuring RDS IAM Access which was a whole different saga.

github.com/aws/aws-acti...
Aws::Rails::SqsActiveJob#execute captures StandardError which is too wide · Issue #6 · aws/aws-activejob-sqs-ruby
Steps to reproduce Set up AWS RDS to manage master passwords and rotate Configure your database details via environment properties Wait for your DB password to change Once step 3 occurs my ActiveRe...
github.com
December 13, 2024 at 8:25 PM
うむむ…
LightsailでWordpressの構築がボタンポチポチすればできるようになったと言うから試してみたけど、何度やっても最後のSSL証明書のところでエラーになる…
このエラーが出ると、パブリックIPアドレスにアクセスしてみるとアクセスできないんだけど、数分するとアクセスできるようになる。

エラーログを見ると、 "standardError": " Error code: CertbotAuthorizationFailed"ってところがそれなんだろうけど、トラブルシューティングにも無いし、他の情報も無く手がかりが無い。

まずはCertbotについて調べないとな…
August 14, 2024 at 1:05 PM
这一切都是谷歌AI的功劳😌

[Unit]
Description=Elasticsearch
After=network.target

[Service]
Type=simple
User=elasticsearch
Group=elasticsearch
ExecStart=/opt/elasticsearch-8.4.1/bin/elasticsearch
StandardOutput=journal
StandardError=journal
LimitNOFILE=65536 […]
Original post on cmx.dongzhim.in
cmx.dongzhim.in
August 29, 2026 at 2:31 PM
April 23, 2026 at 1:44 AM
C#の例外処理ってどうやるものなんだろうか。
Javaの場合アプリケーションで補足すべきでないErrorと通常のExceptionが分けられているし、RubyもStandardErrorとそれ以外で区別されている。一方C#ではそのような区別は無いっぽい。
そうかといって投げる可能性のある例外の明示が型などで強制されている訳でもない。
雰囲気で例外処理するしかない?
May 4, 2025 at 10:14 AM
Restore fails due to disk space on migration I’ve got a standard install that’s trying to restore a database. It is failing on the migration. ALTER TABLE Migrating the database... EXCEPTION: ra...

#Hosting

Origin | Interest | Match
Restore fails due to disk space on migration
I’ve got a standard install that’s trying to restore a database. It is failing on the migration. ALTER TABLE Migrating the database... EXCEPTION: rake db:migrate Failed to migrate database. rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) PG::DiskFull: ERROR: could not write to file "base/pgsql_tmp/pgsql_tmp11009.51": No space left on device /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rack-mini-profiler-4.0.1/lib/patches/db/pg/a...
meta.discourse.org
February 11, 2026 at 1:34 AM
Restore fails due to disk space on migration I’ve got a standard install that’s trying to restore a database. It is failing on the migration. ALTER TABLE Migrating the database... EXCEPTION: ra...

#Hosting

Origin | Interest | Match
Restore fails due to disk space on migration
I’ve got a standard install that’s trying to restore a database. It is failing on the migration. ALTER TABLE Migrating the database... EXCEPTION: rake db:migrate Failed to migrate database. rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) PG::DiskFull: ERROR: could not write to file "base/pgsql_tmp/pgsql_tmp11009.51": No space left on device /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rack-mini-profiler-4.0.1/lib/patches/db/pg/a...
meta.discourse.org
February 9, 2026 at 8:32 PM
Migration error in 'rename_discourse_rewind_disabled_to_enabled' 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An e...

#Installation

Origin | Interest | Match
Migration error in 'rename_discourse_rewind_disabled_to_enabled'
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/pos...
meta.discourse.org
January 10, 2026 at 10:32 AM
Migration error in 'rename_discourse_rewind_disabled_to_enabled' 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An e...

#Installation

Origin | Interest | Match
Migration error in 'rename_discourse_rewind_disabled_to_enabled'
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/pos...
meta.discourse.org
January 10, 2026 at 7:17 AM
Migration error in 'rename_discourse_rewind_disabled_to_enabled' 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An e...

#Installation

Origin | Interest | Match
Migration error in 'rename_discourse_rewind_disabled_to_enabled'
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/pos...
meta.discourse.org
January 10, 2026 at 5:28 AM
Migration error in 'rename_discourse_rewind_disabled_to_enabled' 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An e...

#Installation

Origin | Interest | Match
Migration error in 'rename_discourse_rewind_disabled_to_enabled'
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/pos...
meta.discourse.org
January 9, 2026 at 7:24 PM
Migration error in 'rename_discourse_rewind_disabled_to_enabled' 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An e...

#Installation

Origin | Interest | Match
Migration error in 'rename_discourse_rewind_disabled_to_enabled'
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/pos...
meta.discourse.org
January 9, 2026 at 2:44 PM
Migration error in 'rename_discourse_rewind_disabled_to_enabled' 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An e...

#Support

Origin | Interest | Match
Migration error in 'rename_discourse_rewind_disabled_to_enabled'
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/pos...
meta.discourse.org
January 9, 2026 at 1:00 PM
While trying to load /admin/docker/repos Error code: 500 error 重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has o...

Origin | Interest | Match
While trying to load /admin/docker/repos Error code: 500 error
重新rebuild 失败了~日志如下: discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before marking it as readonly I, [2026-01-08T16:18:49.016491 #1] INFO -- : Terminating async processes I, [2026-01-08T16:18:49.018961 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/15/bin/postmaster -D /etc/postgresql/15/main pid: 46 I, [2026-01-08T16:18:49.020147 #1] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 113 2026-01-08 16:18:49.019 UTC [46] LOG: received fast shutdown request 113:signal-handler (1767889129) Received SIGTERM scheduling shutdown... 2026-01-08 16:18:49.023 UTC [46] LOG: aborting any active transactions 2026-01-08 16:18:49.034 UTC [46] LOG: background worker "logical replication launcher" (PID 60) exited with exit code 1 2026-01-08 16:18:49.040 UTC [55] LOG: shutting down 2026-01-08 16:18:49.042 UTC [55] LOG: checkpoint starting: shutdown immediate 2026-01-08 16:18:49.057 UTC [55] LOG: checkpoint complete: wrote 32 buffers (0.1%); 0 WAL file(s) added, 0 removed, 0 recycled; write=0.007 s, sync=0.004 s, total=0.017 s; sync files=16, longest=0.002 s, average=0.001 s; distance=180 kB, estimate=180 kB 2026-01-08 16:18:49.067 UTC [46] LOG: database system is shut down 113:M 08 Jan 2026 16:18:49.108 # User requested shutdown... 113:M 08 Jan 2026 16:18:49.108 * Saving the final RDB snapshot before exiting. 113:M 08 Jan 2026 16:18:49.123 * DB saved on disk 113:M 08 Jan 2026 16:18:49.123 # Redis is now ready to exit, bye bye... FAILED -------------------- Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 4483 exit 1> Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.3.0/lib/pups/exec_command.rb:131:in `spawn' exec failed with the params {"cd"=>"$home", "tag"=>"migrate", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]} bootstrap failed with exit code 1 ** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one. ./discourse-doctor may help diagnose the problem.
meta.discourse.org
January 8, 2026 at 6:39 PM