#ExternalData
CVE-2026-100382 - mediawiki - externaldata extension
The ExternalData add‑on for Mediawiki can be tricked into executing system commands without any authentication. This means an attacker could run…

Too many irrelevant or confusing CVEs? Use stackflag.com

#wikimediafoundation #CVE #infosec
CVE-2026-100382: Unauthenticated remote code execution through wikitext in ExternalData
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Wikimedia Foundation Mediawiki - ExternalData.
stackflag.com
September 26, 2026 at 4:00 PM
Tip of the day: You can utilize data from external sources in Kusto by using the externaldata operator! For example, if you have a C2 list from GitHub, simply reference it using this operator. It makes working with external data a breeze!
externaldata operator - Kusto
Learn how to use the externaldata operator to return a data table of the given schema whose data was parsed from the specified storage artifact.
learn.microsoft.com
January 20, 2025 at 6:01 AM
CRITICAL OS Command Injection in Mediawiki ExternalData Extension (<3.7) allows remote command execution. Restrict access and monitor until vendor patch. No known exploits. https://radar.offseq.com/threat/improper-neutralization-of-special-elements-used-in-an-os-command-os-command-injection-vulne...
Improper Neutralization of Special Elements used in an OS Command ('OS Command I
The Wikimedia Foundation Mediawiki ExternalData Extension contains an OS Command Injection vulnerability (CVE-2026-100382) due to improper neutralization of special elements in OS commands. This flaw allows an attacker to inject and execute
radar.offseq.com
September 26, 2026 at 9:00 AM
CVE-2026-100382: CRITICAL OS Command Injection in Mediawiki ExternalData Extension (<3.7). Remote attackers can run arbitrary commands. Restrict access & monitor for signs of compromise. https://radar.offseq.com/threat/cve-2026-100382-cwe-78-improper-neutralization-of-special-elements-used-in-an-...
CVE-2026-100382: CWE-78 Improper Neutralization of Special Elements used in an O
This vulnerability (CVE-2026-100382) in the Mediawiki ExternalData Extension arises from improper neutralization of special elements in OS commands, classified as CWE-78 (OS Command Injection). It allows unauthenticated remote attackers to
radar.offseq.com
September 26, 2026 at 12:00 AM
Il est conseillé de télécharger les données sur Odissé, puis de les cartographier avec l'application CartoSanté qui permet d'importer des données externes (idem pour SIRSé)
cartosante.atlasante.fr#c=externaldata
7/
October 30, 2025 at 8:08 AM
#KQL query that looks for network connections to these domains via #MDE DeviceNetworkEvents (Connection or DNS Query).

github.com/SecurityAura...

Huge thanks to @RacWatchin8872 (on Twitter/X) for making the data available in a way that can be accessed via externaldata 🙏
github.com
June 2, 2025 at 4:19 PM
実はゲームのローカルデータにテキストで職員の台詞はそのまま格納されておりますので、ご自分の環境で確認することが出来ます!是非やってみてください

ちなみに現行版の台詞は
Steam\steamapps\common\LobotomyCorp\LobotomyCorp_Data\ExternalData\xml\Language\jp\AgentNewLyrics_jp.xml
にあります!(AgentLyrics_jp.xmlがレガシー版です)
July 9, 2025 at 4:51 PM
Enforce Sigstore/Cosign image signature checks in Kubernetes via Gatekeeper ExternalData by offloading validation to an external HTTP provider endpoint.

#gatekeeper #opa #ValtersIT

https://www.valtersit.com/vault/enforce-container-image-signature-verification-via-external--c95ecb/
September 6, 2026 at 7:21 PM
KQL: ExternalData - Cert Central, CertReport - "If this returns TRUE, it means that the cert has been reported in CertReport and therefore, there are high chances that this file is malicious."
KQL: ExternalData - Cert Central, CertReport - "If this returns TRUE, it means that the cert has been reported in CertReport and therefore, there are high chances that this file is malicious."
github.com
August 25, 2025 at 8:09 AM
Hunting Chrome Extensions with Hidden Tracking Code

Based on the latest BleepingComputer blog, there are 6 million Chrome extension installs with risky hidden tracking code. These extensions can monitor browsing behavior, access cookies, and execute remote scripts. KQL Query to Detect Risky…
Hunting Chrome Extensions with Hidden Tracking Code
Based on the latest BleepingComputer blog, there are 6 million Chrome extension installs with risky hidden tracking code. These extensions can monitor browsing behavior, access cookies, and execute remote scripts. KQL Query to Detect Risky Extensions Use the following Kusto Query Language (KQL) to check if any enterprise users are affected: let SecureAnnex=externaldata(extension_id:string) ; let MID = SecureAnnex | project extension_id;
undercodetesting.com
April 18, 2025 at 5:19 AM
NEW BLOG! 🚨

IOC hunting at scale using externaldata().

The blog includes queries for:
- Suspicious NamedPipes
- Tor connections
- Active CISA KEV vulnerabilities
- MISP Feeds

kqlquery.com/posts/extern...
IOC hunting at scale
The KQL External Data operator might be the holiday gift for you! This powerful capability enables you to seamlessly incorporate external data into your KQL queries, such as GitHub IOC lists or MISP F...
kqlquery.com
December 18, 2024 at 3:42 PM
This project is so damn cool!

#KQL queries to find #LOLDrivers 🔥

//Remove [] in URL
DeviceFileEvents
| where FileName has ".sys"
| distinct SHA1
| where SHA1 in (externaldata(hash:string)["https://github[.]com/magicsword-io/LOLDrivers/raw/main/detections/hashes/samples.sha1"]) https://t.co/rm...
November 17, 2024 at 11:31 PM
Oh hell yeah, this is cool!

DeviceNetworkEvents
| where RemoteIPType == "Public"
| where InitiatingProcessVersionInfoOriginalFileName in ((
externaldata ( Name:string ) [ "https://t.co/m8rJbl7KnU" ]
with (format=csv, ignoreFirstRecord=true) | distinct Name
))

#MDE https://t.co/WV2ix4yNbf
November 17, 2024 at 11:17 PM