infer expr = case expr of
Var name -> lookupVarType name ?env
App funExpr bodyExpr -> do
funType <-infer funExpr
(paramType, resultType) <- splitFunction funType
check paramType bodyExpr
pure resultType
infer expr = case expr of
Var name -> lookupVarType name ?env
App funExpr bodyExpr -> do
funType <-infer funExpr
(paramType, resultType) <- splitFunction funType
check paramType bodyExpr
pure resultType
#Flutter #FlutterDev #Dart #ErrorHandling #Either #ResultType #FlutterError #Crashlytics #Sentry #FlutterInterview #MobileDevelopment #TechInterview
#Flutter #FlutterDev #Dart #ErrorHandling #Either #ResultType #FlutterError #Crashlytics #Sentry #FlutterInterview #MobileDevelopment #TechInterview
infer env expr = case expr of
Var name -> lookupVarType name env
App funExpr bodyExpr -> do
funType <- infer env funExpr
(paramType, resultType) <- splitFunction funType
check env paramType bodyExpr
pure resultType
infer env expr = case expr of
Var name -> lookupVarType name env
App funExpr bodyExpr -> do
funType <- infer env funExpr
(paramType, resultType) <- splitFunction funType
check env paramType bodyExpr
pure resultType
SigninLogs
| summarize uniqueCount = dcount(UserAgent), make_set(UserAgent),make_set(ResultType),make_set(IPAddress) by bin(TimeGenerated, 10m), UserPrincipalName
| where set_UserAgent has_all ('Android','Macintosh','iPhone','Windows phone')
SigninLogs
| summarize uniqueCount = dcount(UserAgent), make_set(UserAgent),make_set(ResultType),make_set(IPAddress) by bin(TimeGenerated, 10m), UserPrincipalName
| where set_UserAgent has_all ('Android','Macintosh','iPhone','Windows phone')
i got hit by a lint rule saying it can’t end in the word “type”
touché linter
i got hit by a lint rule saying it can’t end in the word “type”
touché linter
https://www.javapedia.net/mybatis-interview-questions/10593/what-is-the-difference-between-resulttype-and-resultmap
#javapedia #interviewquestions #programming #shorts #mybatis
https://www.javapedia.net/mybatis-interview-questions/10593/what-is-the-difference-between-resulttype-and-resultmap
#javapedia #interviewquestions #programming #shorts #mybatis
```c
typedef struct {
ResultType type;
union {
int value; // 成功時の値
char error_message[128]; // 失敗時のエラーメッセージ
};
} Result;
```
```c
typedef struct {
ResultType type;
union {
int value; // 成功時の値
char error_message[128]; // 失敗時のエラーメッセージ
};
} Result;
```
The list keeps on getting crazier the longer you look at it
The list keeps on getting crazier the longer you look at it
The list keeps on getting crazier the longer you look at it
The list keeps on getting crazier the longer you look at it
Monitoring the M365 Connector for Claude is critical because when ResultType=0, it means an Entra Global Admin has granted permissions, enabling Claude to directl…
🔁 RT @0x534c | reposted by @cyb3rops
https://x.com/0x534c/status/2040297460036485371
Monitoring the M365 Connector for Claude is critical because when ResultType=0, it means an Entra Global Admin has granted permissions, enabling Claude to directl…
🔁 RT @0x534c | reposted by @cyb3rops
https://x.com/0x534c/status/2040297460036485371